Output Formats

To save a table use the File > Save or File > Save As menu options. To save the entire table you must have either nothing highlighted/selected or the entire table highlighted/selected.

If SuperCROSS displays a progress bar during the save process, you can cancel the save at any time by pressing Esc.

Available Output Formats

FormatDescription
SuperCROSS (.SCS)The native SuperCROSS table file format.
SuperTABLE Dissemination (.SCS)For use in SuperTABLE.
Tab-delimited Table (.TXT)A tab-delimited text file format representing the table structure.
Comma-separated Table (.CSV)

The table data, in CSV (Comma Separated Value) format, including the headers, footers, and any annotations.

Nested row fields and wafers will be flattened into individual rows. For example:

You must run the tabulation before saving the output, otherwise there will be no values in the CSV file.

Tabular Macro-data (.CSV)

The table data, in CSV format. The output is similar to standard CSV, except that it does not include headers, footers or annotations and there is no column heading row. For example:

You must run the tabulation before saving the output, otherwise there will be no values in the CSV file.

Tabular Meta-data (.TXT)The table metadata. This includes the database, table subject population, table fields, and structure of enumerated axes (blank items are used to indicate spanners, and space indentation are used to indicate the hierarchy).
Flattened Tabular Macro-data (.CSV)

The table data, in flattened CSV format. This format is similar to the other CSV output formats except that all fields (including fields on the columns) are flattened into the rows. It includes a single header row that identifies the contents of the columns, but does not include the SuperCROSS header and footer or any annotations. Features such as sorting and ordering are also removed from the table before saving.

If your table contains any concatenated fields, these will be separated by a pipe character in the header row (|), while all other fields are separated with a comma.

For example:

If your table has multiple summation options, then these will be output in the columns. For example:

You must run the tabulation before saving the output, otherwise there will be no values in the CSV file.

TXD and Macro-data

The TXD and Flattened Tabular Macro-data formats combined into a ZIP file. As the purpose of this output format is to combine table structure and data into a single file, it does not make sense to save this format without any data. For this reason, if the cross tabulation has not been run, you will be prompted to confirm if you want to tabulate before saving:

If you click Yes, the ZIP file will be saved automatically as soon as the tabulation completes.

This format also includes MD5 hashes of both the TXD and the flattened Macro-data file and the combined hash, so you can verify the integrity of the downloaded files.

In addition, you can change the output format that is included in the ZIP file by adding a [JointOutputFormat] section to the super.ini configuration file. See super.ini for more details.

Parameter Log (.TXT)

A textual description of the table and tabulation. Parameter logs can be used for manually checking how a table was created or for reference.

The output text file includes:

  • The number and name of fields used in each axis of the table,
  • The values included in recodes.
  • How both derivations and User Defined Files (UDFs) were created.
  • Table file name.
  • User Name.
  • Computer Name.
  • Server user name (if saved via the server).
  • Server application name (if saved via the server).
  • Tabulation start time.
  • Axis derivations.
  • Ranges for individually added items (if medium number). 
HTML - Single File (.HTM)

The entire table saved as a single HTML file. If there are multiple wafers in the table they are displayed one after the other on the page.

There are a number configuration options you can set for saving to HTML. See super.ini for more information.

HTML - Multiple Files (.HTM)

Each wafer is saved to its own individual HTML file.

There are a number configuration options you can set for saving to HTML. See super.ini for more information.

XML - Display Model (.XML)

An XML file format containing data elements and table metadata.

The XML file contains the following:

  • Spanner labels.
  • Groups.
  • Summation options.
  • Field and cell values.
  • Annotation data.
  • Field derivations.
  • Axis derivations.

These elements are tagged for identification. Table wafer data is generated as a separate section of the XML output. However, hierarchical levels are not tagged, and nesting of levels is not supported.

  • Tables must be tabulated prior to saving out to XML format.
  • If you want to display the XML file in a web browser you will need to attach the SuperCROSS XSL style sheet (available in the SuperCROSS\XML Style Sheets directory located in the SuperCROSS Program Files directory).  
XML - Structural Model (.XML)

This is a structured model XML file.

  • Tables must be tabulated prior to saving out to XML format.
  • The table can not contain a Block Percent.
  • This format is only available for SXV4 databases.
XML - CALS Model (.XML)

This is a statistical table model that is based on the CALS table model.

  • Tables must be tabulated prior to saving out to XML format.
  • The table can not contain a Block Percent.
  • This format is only available for SXV4 databases.
Excel 97-2003 (.XLS) and Excel 2007 or 2010 (.XLSX)

For opening in Microsoft Excel.

  • By default the table header displays left justified.
  • The .xls file format (Excel 97-2003) is limited to 65.536 rows.  
  • The .xlsx file format (Excel 2007/2010) is limited to 16,384 columns and 1,048,576 rows.

If SuperCROSS is set up with multilingual metadata, you can use this option to export to Excel with table and field titles in two languages. Learn more.

There are a number configuration options you can set for saving to Excel. See super.ini for more information.

SDMX Structure Definition (.xml)

The SDMX (Statistical Data and Metadata eXchange) Technical Standards Version 2.0 format.

This output format saves the structure definition only.

Items that can be saved to the SDMX download file include:

  • Simple tables.
  • Totals.
  • Mathematical functions applied to summations.
  • Non-default summation options.
  • Percentages.
  • Cell annotations.
  • Field annotations.
  • DAG classification hierarchies.
  • Derivations.
  • User defined functions.
  • Table language set to another language.
  • Survey dates.
  • Recodes.

Items that are not saved to the SDMX download file include:

  • Hidden fields.
  • Axis derivations.
  • Grand totals.

SDMX output cannot be saved from tables with concatenated fields.

For more information on SDMX, see http://sdmx.org/ or SDMX.

SDMX Archive (.zip)

The SDMX (Statistical Data and Metadata eXchange) Technical Standards Version 2.0 format.

This output format creates a ZIP archive containing both the SDMX data set and the SDMX structure definition, both in XML format.

The limitations are the same as those of the Structure Definition listed above.

PC-Axis (.PX) and PC-Axis 2000 (.PX)

For use in the PCAxis and PC-Axis 2000 software.

  • The .PX file format can be saved as Production Utility output and as an output format when the application is operating in server mode.
  • All table cells are saved to the PC-Axis and PC-Axis 2000 format regardless of what is currently selected.
  • A maximum of two table axes can be saved to PC-Axis and PC-Axis 2000 file format.
  • Tables containing wafer fields are nested in the row axis.
  • Axis derivations are not saved.
  • Table meta information is available from the Footnote section of the PC-Axis/PC-Axis 2000 window.  
SuperCUBE (.SRD)

A 'Summary Record Database' for distributing to other users of SuperCROSS and SuperTABLE.

For more information about the SuperCUBE output format, see SuperCUBE.

Textual Table Definition (.TXD)

A textual description of a table. TXD files do not contain table data, they only describe the table structure. The TXD must be loaded back into an application like SuperCROSS to view the table it describes.

For a full description of the TXD format, see: TXD Reference

If you save a table containing an annex file in TXD format, the annex file is saved in the same folder as the TXD file, with a RTF file extension. A reference to the RTF file is made in the TXD file. If you move or copy the TXD file you must also move or copy the RTF associated RTF annex information file.

There are a number configuration options you can set for saving to TXD. See super.ini for more information.

Output Encoding

Some of the text-based output formats from SuperCROSS give you the option to select the encoding of the output file:

By default, SuperCROSS will encode the output in UTF-8 (Unicode). This provides full support for any characters in any language that might need to be included in the file.

By default, SuperCROSS saves CSV files in UTF-8 without a Byte Order Mark (BOM). Microsoft Excel requires the BOM to correctly interpret the file as UTF-8. If you are having problems viewing your file in Excel then you should use Unicode (UTF-8 with BOM) instead.

The following encodings are available:

Unicode (UTF-8)The default. It provides full support for all languages and characters.
Unicode (UTF-8 with BOM)

UTF-8 with a Byte Order Mark (BOM) at the start of the file to identify the encoding used. Recommended if you intend to use the file with Microsoft Excel.

Some very old applications may not support UTF-8 files with a BOM, and may show the following three characters at the start of the file:


ANSI/System Locale

Use the current system locale. You may need to use this option if you are going to load the saved file into a system or application that does not support Unicode.

Do not use this option unless the current system locale supports all the characters that have been used in the table.

You can change the default encoding by editing the setting in Edit > Options > Configuration > Output Module > Output Encoding Type, or by changing the value of OutputEncoding in the super.ini configuration file.

Order of Output Formats

If you wish, you can configure the order in which the output formats appear in the drop-down list. See SuperModule.ini for more details about this configuration adjustment.